Calculateur de sous-réseau IPv6
Saisissez une adresse IPv6 avec une longueur de préfixe (notation CIDR) pour obtenir le réseau, la première et la dernière adresse et le nombre total d’adresses. L’adresse est aussi réécrite sous sa forme standard (RFC 5952).
Comment le calcul est effectué
Une adresse IPv6 compte 128 bits. Une longueur de préfixe n signifie que les n bits de gauche identifient le réseau.
- Adresse réseau = l’adresse dont les (128 − n) bits de droite sont mis à 0.
- Dernière adresse = l’adresse réseau dont les (128 − n) bits de droite sont mis à 1.
- Nombre d’adresses = 2 puissance (128 − n).
- Nombre de sous-réseaux /64 = 2 puissance (64 − n) (lorsque n vaut 64 ou moins).
Le calcul utilise des nombres entiers de 128 bits (BigInt) : il n’y a donc aucune erreur d’arrondi. Toutes les longueurs de préfixe, de 0 (toutes les adresses) à 128 (une seule adresse), fonctionnent. IPv6 n’a pas d’adresse de diffusion (broadcast) : contrairement au calculateur de sous-réseau IPv4, cet outil n’affiche donc ni adresse de diffusion ni nombre d’hôtes utilisables (total − 2). La plage est donnée par sa première et sa dernière adresse.
Comment une adresse s’écrit (RFC 4291)
Une adresse IPv6 peut s’écrire de ces manières (RFC 4291, section 2.2) :
- Huit groupes séparés par des deux-points :
2001:db8:0:0:8:800:200c:417a. Chaque groupe compte de 1 à 4 chiffres hexadécimaux, et les zéros en tête peuvent être omis. - « :: » à la place de groupes de zéros : « :: » représente un ou plusieurs groupes de 16 bits à zéro et ne peut apparaître qu’une seule fois dans une adresse. Il peut se trouver au début ou à la fin (
2001:db8::8:800:200c:417a,::1et::). - Les 32 derniers bits écrits comme une adresse IPv4 :
::ffff:192.0.2.1(la partie IPv4 comporte quatre nombres sans zéro en tête).
Un préfixe s’écrit adresse/longueur-du-préfixe (RFC 4291, section 2.3). L’adresse à gauche peut avoir des bits à 1 dans la partie hôte ; cet outil affiche l’adresse réseau avec la partie hôte mise à zéro.
Normalisation (RFC 5952)
Comme une même adresse peut s’écrire de nombreuses façons, la RFC 5952 définit une seule forme canonique. L’« adresse normalisée » de cet outil suit ses règles :
- Les zéros en tête d’un groupe sont toujours omis (
2001:0db8::0001devient2001:db8::1). Un groupe 0000 s’écrit0. - « :: » raccourcit autant que possible (
2001:db8:0:0:0:0:2:1devient2001:db8::2:1). - « :: » n’est pas utilisé pour un seul groupe de zéros (
2001:db8:0:1:1:1:1:1est correct, et2001:db8::1:1:1:1:1ne l’est pas). - S’il y a un choix, la plus longue suite de groupes à zéro est raccourcie (
2001:0:0:1:0:0:0:1devient2001:0:0:1::1). Si deux suites ont la même longueur, la première est raccourcie (2001:db8:0:0:1:0:0:1devient2001:db8::1:0:0:1). - Les lettres a à f sont écrites en minuscules (
2001:DB8::1devient2001:db8::1).
Pour une adresse IPv4-mapped (dans la plage ::ffff:0:0/96), la RFC 5952 (section 5) recommande la notation mixte avec la partie IPv4 en décimal (::ffff:192.0.2.1). Cet outil affiche cette notation mixte uniquement pour les adresses de la plage IPv4-mapped, à titre indicatif.
Exemples
- 2001:db8::1/64 : réseau
2001:db8::/64, première2001:db8::, dernière2001:db8::ffff:ffff:ffff:ffff, 18 446 744 073 709 551 616 adresses (2^64), un sous-réseau /64. - 2001:db8::/32 : 2^32 (4 294 967 296) sous-réseaux /64.
- 2001:db8::1/127 : deux adresses (
2001:db8::et2001:db8::1). Un /127 est utilisé sur les liaisons point à point entre routeurs (RFC 6164). - 2001:db8::1/128 : une seule adresse.
- ::/0 : toutes les adresses (2^128).
- ::ffff:192.0.2.1/128 : normalisée
::ffff:c000:201, notation mixte::ffff:192.0.2.1.
La première adresse d’un sous-réseau
La première adresse d’un sous-réseau (avec un identifiant d’interface entièrement à zéro) est réservée comme adresse anycast Subnet-Router (RFC 4291, section 2.6.1). Chaque routeur doit la prendre en charge sur les sous-réseaux auxquels il est rattaché.
Remarques
- Saisissez toujours la longueur du préfixe (par exemple « /64 »), un nombre entier de 0 à 128. Un nombre avec un zéro en tête, comme « /064 », n’est pas accepté.
- Un identifiant de zone (le
%eth0defe80::1%eth0) et les crochets ([2001:db8::1]) ne sont pas pris en charge. L’outil n’indique pas de quel type d’adresse il s’agit (globale, lien local, etc.). - Les chiffres et symboles pleine chasse sont convertis en caractères ordinaires avant la lecture.
- Les adresses d’exemple sont dans
2001:db8::/32, le préfixe réservé à la documentation (RFC 3849). - Pour convertir des nombres d’une base à l’autre, utilisez le convertisseur de bases numériques.
Sources et vérification
La notation, la normalisation et les mentions d’adresses réservées ci-dessus ont été vérifiées dans le texte intégral de ces RFC le 1er novembre 2026 :
- RFC 4291, IP Version 6 Addressing Architecture (section 2.2 notation, 2.3 préfixes, 2.5.5.2 adresses IPv4-mapped, 2.6.1 anycast Subnet-Router).
- RFC 5952, A Recommendation for IPv6 Address Text Representation (section 4 forme canonique, section 5 adresses spéciales, section 7 préfixes).
- RFC 3849, IPv6 Address Prefix Reserved for Documentation.
- RFC 6164, Using 127-Bit IPv6 Prefixes on Inter-Router Links.
Questions fréquentes
Quelle adresse est l’adresse de diffusion IPv6 ?
IPv6 n’a pas d’adresse de diffusion. Ce que fait la diffusion en IPv4 se fait par multicast en IPv6. Cet outil affiche la première et la dernière adresse de la plage.
Que signifie « :: » ?
Un ou plusieurs groupes de 16 bits à zéro. Il ne peut être utilisé qu’une seule fois dans une adresse. Dans la forme canonique (RFC 5952), il remplace la plus longue suite de groupes à zéro (la première si deux sont de même longueur), et il n’est pas utilisé pour un seul groupe à zéro.
Combien d’adresses y a-t-il dans un /64 ?
2^64, soit 18 446 744 073 709 551 616.
Pourquoi une même adresse peut-elle s’écrire de différentes façons ?
Les zéros en tête peuvent être omis ou conservés, « :: » peut se placer à différents endroits et les lettres peuvent être en majuscules ou en minuscules. Réécrire une adresse sous la forme canonique de la RFC 5952 donne le même texte pour la même adresse.